$re = '/\.(woff|svg|ttf|eot)/';
$str = 'app.svg
app.eot
app.woff
app.ttf';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;