using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*)(\d)";
string substitution = @"$1 $2";
string input = @"CB30QB
N12NL
CB249LQ
OX144FB
OX145FB";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}