package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*)(\d)`)
var str = `CB30QB
N12NL
CB249LQ
OX144FB
OX145FB`
var substitution = "$1 $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}