use strict;
my $str = 'CB30QB
N12NL
CB249LQ
OX144FB
OX145FB';
my $regex = qr/^(.*)(\d)/mp;
my $subst = '$1 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";