$re = '/^(.*)(\d)/m';
$str = 'CB30QB
N12NL
CB249LQ
OX144FB
OX145FB';
$subst = "$1 $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;