# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(\\/)?span([^>]*)>//g;t' <<< "<span style=\"font-weight: bold;\" class=\"Apple-style-span\">A</span>
<span id=\"\">B</span>
<span>C</span>"