$re = '/<(\/)?span([^>]*)>/';
$str = '<span style="font-weight: bold;" class="Apple-style-span">A</span>
<span id="">B</span>
<span>C</span>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;