package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<(\/)?span([^>]*)>`)
var str = `<span style="font-weight: bold;" class="Apple-style-span">A</span>
<span id="">B</span>
<span>C</span>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}