re = /<(\/)?span([^>]*)>/
str = '<span style="font-weight: bold;" class="Apple-style-span">A</span>
<span id="">B</span>
<span>C</span>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result