import Foundation
let pattern = #"<(\/)?span([^>]*)>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<span style="font-weight: bold;" class="Apple-style-span">A</span>
<span id="">B</span>
<span>C</span>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)