use strict;
my $str = '<span style="font-weight: bold;" class="Apple-style-span">A</span>
<span id="">B</span>
<span>C</span>';
my $regex = qr/<(\/)?span([^>]*)>/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";