// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<(\/)?span([^>]*)>").unwrap();
let string = "<span style=\"font-weight: bold;\" class=\"Apple-style-span\">A</span>
<span id=\"\">B</span>
<span>C</span>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}