# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.{8})(.{4})(.{4})(.{4})(.{4})(.*)$/$1-$2-$3-$4-$5/;t' <<< "fb396a80cada446f9e63d871116b8ddf"