$re = '/^(.{8})(.{4})(.{4})(.{4})(.{4})(.*)$/';
$str = 'fb396a80cada446f9e63d871116b8ddf';
$subst = "$1-$2-$3-$4-$5";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;