package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(.{8})(.{4})(.{4})(.{4})(.{4})(.*)$`)
var str = []byte(`fb396a80cada446f9e63d871116b8ddf`)
var substitution = []byte("$1-$2-$3-$4-$5")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}