re = /^(.{8})(.{4})(.{4})(.{4})(.{4})(.*)$/
str = 'fb396a80cada446f9e63d871116b8ddf'
subst = '$1-$2-$3-$4-$5'
result = str.sub(re, subst)
# Print the result of the substitution
puts result