using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.{8})(.{4})(.{4})(.{4})(.{4})(.*)$";
string substitution = @"$1-$2-$3-$4-$5";
string input = @"fb396a80cada446f9e63d871116b8ddf";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}