#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(.{8})(.{4})(.{4})(.{4})(.{4})(.*)$"
Local $sString = "fb396a80cada446f9e63d871116b8ddf"
Local $sSubst = "$1-$2-$3-$4-$5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)