import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.{8})(.{4})(.{4})(.{4})(.{4})(.*)$";
final String string = "fb396a80cada446f9e63d871116b8ddf";
final String subst = "$1-$2-$3-$4-$5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}