const regex = /^(.{8})(.{4})(.{4})(.{4})(.{4})(.*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.{8})(.{4})(.{4})(.{4})(.{4})(.*)$', '')
const str = `fb396a80cada446f9e63d871116b8ddf`;
const subst = `$1-$2-$3-$4-$5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);