// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(.{8})(.{4})(.{4})(.{4})(.{4})(.*)$").unwrap();
let string = "fb396a80cada446f9e63d871116b8ddf";
let substitution = "$1-$2-$3-$4-$5";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}