using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"v?\s*(\d+(\.\d*)*)+\s*(beta|build|b)\s*(\d+)";
string input = @"v1.23beta125
v1.25.458 beta 129
v1 beta 129
1.2.4 beta 134
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}