package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`v?\s*(\d+(\.\d*)*)+\s*(beta|build|b)\s*(\d+)`)
var str = `v1.23beta125
v1.25.458 beta 129
v1 beta 129
1.2.4 beta 134
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}