import Foundation
let pattern = #"v?\s*(\d+(\.\d*)*)+\s*(beta|build|b)\s*(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
v1.23beta125
v1.25.458 beta 129
v1 beta 129
1.2.4 beta 134
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)