re = /v?\s*(\d+(\.\d*)*)+\s*(beta|build|b)\s*(\d+)/
str = 'v1.23beta125
v1.25.458 beta 129
v1 beta 129
1.2.4 beta 134
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end