import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "v?\\s*(\\d+(\\.\\d*)*)+\\s*(beta|build|b)\\s*(\\d+)";
final String string = "v1.23beta125\n"
+ "v1.25.458 beta 129\n"
+ "v1 beta 129\n"
+ "1.2.4 beta 134\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}