// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"v?\s*(\d+(\.\d*)*)+\s*(beta|build|b)\s*(\d+)").unwrap();
let string = "v1.23beta125
v1.25.458 beta 129
v1 beta 129
1.2.4 beta 134
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}