const regex = /v?\s*(\d+(\.\d*)*)+\s*(beta|build|b)\s*(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('v?\\s*(\\d+(\\.\\d*)*)+\\s*(beta|build|b)\\s*(\\d+)', 'g')
const str = `v1.23beta125
v1.25.458 beta 129
v1 beta 129
1.2.4 beta 134
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}