use strict;
my $str = 'v1.23beta125
v1.25.458 beta 129
v1 beta 129
1.2.4 beta 134
';
my $regex = qr/v?\s*(\d+(\.\d*)*)+\s*(beta|build|b)\s*(\d+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}