# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<img.*?src=")((?:\w+\\/)+?)([\w-]+\.(?:jpg|jpeg|png|gif))"/$1{#CDNPath#}img\/$3"/g;t' <<< "<img src=\"index_files/bottle2.jpg\" name=\"product ds Grodsdwth\" class=\"pullleft\">
<img title=\"\" src=\"index_files/ss-button.png\" class=\"step-btn\" alt=\"\"></a>
<img src=\"index_files/a/bottle2.jpg\" name=\"product ds Grodsdwth\" class=\"pullleft\">"