import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<img.*?src=\")((?:\\w+\\/)+?)([\\w-]+\\.(?:jpg|jpeg|png|gif))\"";
final String string = "<img src=\"index_files/bottle2.jpg\" name=\"product ds Grodsdwth\" class=\"pullleft\">\n\n"
+ "<img title=\"\" src=\"index_files/ss-button.png\" class=\"step-btn\" alt=\"\"></a>\n\n"
+ "<img src=\"index_files/a/bottle2.jpg\" name=\"product ds Grodsdwth\" class=\"pullleft\">";
final String subst = "$1{#CDNPath#}img/$3\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}