#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<img.*?src=")((?:\w+\/)+?)([\w-]+\.(?:jpg|jpeg|png|gif))""
Local $sString = "<img src="index_files/bottle2.jpg" name="product ds Grodsdwth" class="pullleft">" & @CRLF & _
"" & @CRLF & _
"<img title="" src="index_files/ss-button.png" class="step-btn" alt=""></a>" & @CRLF & _
"" & @CRLF & _
"<img src="index_files/a/bottle2.jpg" name="product ds Grodsdwth" class="pullleft">"
Local $sSubst = "$1{#CDNPath#}img/$3""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)