// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<img.*?src=")((?:\w+\/)+?)([\w-]+\.(?:jpg|jpeg|png|gif))""#).unwrap();
let string = "<img src=\"index_files/bottle2.jpg\" name=\"product ds Grodsdwth\" class=\"pullleft\">
<img title=\"\" src=\"index_files/ss-button.png\" class=\"step-btn\" alt=\"\"></a>
<img src=\"index_files/a/bottle2.jpg\" name=\"product ds Grodsdwth\" class=\"pullleft\">";
let substitution = "$1{#CDNPath#}img/$3\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}