import Foundation
let pattern = #"(<img.*?src=")((?:\w+\/)+?)([\w-]+\.(?:jpg|jpeg|png|gif))""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<img src="index_files/bottle2.jpg" name="product ds Grodsdwth" class="pullleft">
<img title="" src="index_files/ss-button.png" class="step-btn" alt=""></a>
<img src="index_files/a/bottle2.jpg" name="product ds Grodsdwth" class="pullleft">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"$1{#CDNPath#}img/$3""##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)