re = /(<img.*?src=")((?:\w+\/)+?)([\w-]+\.(?:jpg|jpeg|png|gif))"/
str = '<img src="index_files/bottle2.jpg" name="product ds Grodsdwth" class="pullleft">
<img title="" src="index_files/ss-button.png" class="step-btn" alt=""></a>
<img src="index_files/a/bottle2.jpg" name="product ds Grodsdwth" class="pullleft">'
subst = '$1{#CDNPath#}img/$3"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result