package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<img.*?src=")((?:\w+\/)+?)([\w-]+\.(?:jpg|jpeg|png|gif))"`)
var str = `<img src="index_files/bottle2.jpg" name="product ds Grodsdwth" class="pullleft">
<img title="" src="index_files/ss-button.png" class="step-btn" alt=""></a>
<img src="index_files/a/bottle2.jpg" name="product ds Grodsdwth" class="pullleft">`
var substitution = "$1{#CDNPath#}img/$3""
fmt.Println(re.ReplaceAllString(str, substitution))
}