import re
regex = re.compile(r"(<img.*?src=\")((?:\w+\/)+?)([\w-]+\.(?:jpg|jpeg|png|gif))\"")
test_str = ("<img src=\"index_files/bottle2.jpg\" name=\"product ds Grodsdwth\" class=\"pullleft\">\n\n"
"<img title=\"\" src=\"index_files/ss-button.png\" class=\"step-btn\" alt=\"\"></a>\n\n"
"<img src=\"index_files/a/bottle2.jpg\" name=\"product ds Grodsdwth\" class=\"pullleft\">")
subst = "$1{#CDNPath#}img/$3\""
result = regex.sub(subst, test_str)
if result:
print(result)