const regex = /(?<=^.)O|(?<=^.{3})O|(?<=^.{5})O/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^.)O|(?<=^.{3})O|(?<=^.{5})O', 'g')
const str = `AOAOAO
O1A1O1`;
const subst = `0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);