import re
regex = re.compile(r"(?<=^.)O|(?<=^.{3})O|(?<=^.{5})O")
test_str = ("AOAOAO\n"
"O1A1O1")
subst = "0"
result = regex.sub(subst, test_str)
if result:
print(result)