re = /(?<=^.)O|(?<=^.{3})O|(?<=^.{5})O/
str = 'AOAOAO
O1A1O1'
subst = '0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result