$re = '/(?<=^.)O|(?<=^.{3})O|(?<=^.{5})O/';
$str = 'AOAOAO
O1A1O1';
$subst = "0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;