# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([+]*)([0-9]+)(([,])([0-9]+))*/$2${3:+.$5:}/gm;t' <<< "+000123,456
+123
000123,456
123
+123.45
-123,45"