$re = '/([+]*)([0-9]+)(([,])([0-9]+))*/m';
$str = '+000123,456
+123
000123,456
123
+123.45
-123,45';
$subst = "$2${3:+.$5:}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;