const regex = /([+]*)([0-9]+)(([,])([0-9]+))*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([+]*)([0-9]+)(([,])([0-9]+))*', 'gm')
const str = `+000123,456
+123
000123,456
123
+123.45
-123,45`;
const subst = `$2${3:+.$5:}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);