// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([+]*)([0-9]+)(([,])([0-9]+))*").unwrap();
let string = "+000123,456
+123
000123,456
123
+123.45
-123,45";
let substitution = "$2${3:+.$5:}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}