use strict;
my $str = '+000123,456
+123
000123,456
123
+123.45
-123,45';
my $regex = qr/([+]*)([0-9]+)(([,])([0-9]+))*/mp;
my $subst = '$2${3:+.$5:}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";