#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([+]*)([0-9]+)(([,])([0-9]+))*"
Local $sString = "+000123,456" & @CRLF & _
"+123" & @CRLF & _
"000123,456" & @CRLF & _
"123" & @CRLF & _
"+123.45" & @CRLF & _
"-123,45"
Local $sSubst = "$2${3:+.$5:}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)