package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([+]*)([0-9]+)(([,])([0-9]+))*`)
var str = `+000123,456
+123
000123,456
123
+123.45
-123,45`
var substitution = "$2${3:+.$5:}"
fmt.Println(re.ReplaceAllString(str, substitution))
}