# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[١٢٣٤٥٦٧٨٩]{4,}//g;t' <<< "١|٢|٣٣٣٣٣|٤٥٥٥|٥|٦|٧|٨|٩"