#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[١٢٣٤٥٦٧٨٩]{4,}"
Local $sString = "١|٢|٣٣٣٣٣|٤٥٥٥|٥|٦|٧|٨|٩"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)